Now, Since the Moodle 3.0 has entered into the Beta version which was released in previous week, so its time to upgrade all the plugins for this new version.
Moodle HQ developer, David Mudrak has announced about the Moodle plugin Triathlon which is a mini-competition among the Moodle plugin developers. I believe that is a nice way to motivate the plugin developers to upgrade their plugins soon. To participate in the competition, you are supposed to:

Post Pages - Post Inline - WIRIS
  • Test your Moodle plugin carefully with the latest Moodle 3.0 code, with full developer debugging enabled. If you have unit tests and/or behat tests available in your plugins, they will help you a lot.
  • Fix all the eventual regressions caused by 3.0. If needed, release a new plugin version with the fixes.
  • Mark at least one fully tested version of your plugin as supporting Moodle 3.0 in time before the actual Moodle 3.0 release.

All plugins that will have these checks done, will receive a special award in the plugins directory (something like Early 3.0 bird or so) as a good sign of being actively maintained.
So, if you are one of the plugin maintainers for any Moodle plugin then you can start today and update your plugin for Moodle 3.0.
Read the full announcement here.

Previous articleHave You Checked Out The Overview Report In 2.9?
Next articleImproving the student experience by Gavin Henrick #mootes15 @ghenrick

LEAVE A REPLY

Please enter your comment!
Please enter your name here

This site uses Akismet to reduce spam. Learn how your comment data is processed.