Support Essential Theme: upgrading it to 3.2 and 3.3

2091

Gareth Barnard is seeking $437 to update the ever-popular Essential Theme to Moodle 3.2 and 3.3. I’m supporting him once more using Moodlegarage.com to facilitate the fund-raising from Essential and Moodle fans far and wide.

WIRIS

This important theme provides users and sites a distinct template to customize their Moodle experience which has continued to evolve and provide a great, responsive, and flexible aesthetic.

Gareth, once more, is not just ensuring compatibility but working to incrementally improve the theme in a couple of ways:

  • Improving / checking the CSS to ensure that it is compatible.
  • Check / add new icons.
  • Check that the overridden course format classes operate correctly.
  • Remove and check all RTL styles as new CSS ‘flip’ mechanism in M3.2. Please see ‘RTLCSS-PHP’ – https://github.com/moodlehq/rtlcss-php.
  • Investigate if it is possible to use the new core ‘logo’ and ‘compactlogo’ settings instead of those in the theme.

If you’re an Essential Theme user, consider supporting this volunteer maintainer for his time. Community funding via Paypal is open through March 2nd (3/2!) @ http://www.moodlegarage.com/