Moodler's – The countdown is Over! Moodle 3.4 is available now #moodle3.4

930

Finally the wait for the next version of Moodle is over!! Moodle 3.4 is now available for release from the usual downloads page and GitHub page of Moodle. The new version is accompanied by other minor point releases for currently supported moodle versions.
The new version of Moodle is focused on Usability and making Moodle more learner friendly. We had already reported about the new features coming in Moodle 3.4. Complete list of changes in new version is available in the Release notes here.
Along with Moodle 3.4, Moodle team had released other point releases like Moodle 3.3.3, Moodle 3.2.6 & Moodle 3.1.9. Moodle 3.2 is not supported only for Security fixes only. The details of the changes in the point release can be found in the release notes here:

Post Pages - Post Inline - WIRIS

Here are some introductory videos to showcase Moodle 3.4 new features:

How to Upgrade?

Following are the prerequisites before starting the upgrade to Moodle 3.4:

  • Moodle upgrade: Moodle 3.0 or later
  • PHP version: minimum PHP 7.0.0
  • PHP extension intl is now required

If you are not clear about the Moodle Upgrade process, please follow this Guide.

Database Requirements:

Moodle recommends to have the latest version of:

Database Recommended Version
PostgreSQL 9.3
MySQL 5.5.31
MariaDB 5.5.31
Microsoft SQL Server 2008
Oracle Database 10.2

When you are upgrading your Moodle site to Moodle 3.4? Do share with us in the comments section below.

LEAVE A REPLY

Please enter your comment!
Please enter your name here

This site uses Akismet to reduce spam. Learn how your comment data is processed.