Development News: Moodle 2.1 to require PHP 5.3 as a minimum


Recently announced by Martin Dougiamas [link], Moodle HQ (like is dropping use of php 5.2.  Future Moodle releases will require PHP 5.3 as a minimum. While this information may not affect the majority of Moodle users, it’s nice to know that Moodle is built upon supported web languages (and is not relying on old or outdated versions).

Post Pages - Post Inline - WIRIS

To learn more about the changes in PHP versions that Moodle will use moving forward visit

Additionally, this got me thinking about what version of PHP my shared hosting at was running.  It took a little sleuthing but it seems that I will be AOK with Bluehost as it is already running PHP5 on my “server”.  If you plan to move to Moodle 2.0 (or already have) check with your server administrator to ensure that an upgrade to Moodle 2.1 will not be a problem.